Sid Meier's Alpha Centauri & Alien Crossfire > After Action Reports

Morgan Biochemical - SMACX AI Growth mod version 1.37

<< < (22/22)

Detailsendgame phenomenonendgame phenomenon
MY 2359.  How is it that I have come into possession of 2 Datatech units on dry land in my home territory?  Even with the land raising I've been doing in the area, I know they didn't exist here last year.  I seem to be able to move the units, although I haven't tried it yet.  I'm attaching a saved game if anyone wants to dissect this later.

The proximity of the newly spawned indigenous life forms, would seem to indicate that these Datatech units have also been spawned, errantly.

Detailsunder unitunder unit
Ok, I can't move the Datatech units.  They were blinking because I have many Formers in the stack with them, invisible.  I'm able to move them, I just have to wait for the game to tell me when it's time to move a unit.

Detailstaking care of businesstaking care of business
Detailscomplete waste of ordinancecomplete waste of ordinance
While watching TV, I pushed my arrow keys too fast and ran into an Isle.  Well that's one of the most annihilated Isles of the game!  And I haven't captured this frame of the explosion animation before, so not a complete loss.

Detailsgated interlopersgated interlopers
I've saved the slaying of the Datatech interlopers for the end of the turn.  They do die when attacked, but they also seem to pop up more units.  I don't know if that's because they were there but invisible, or if a bug is summoning more units to the location.  It's as though the contents of a fairly large city have been relocated here.  I save the game every so often to hopefully make forward progress on eliminating them.

Detailsthe well of dead soulsthe well of dead souls
I threw more units at it, but I'm running out of nearby units to move.  I even dropped a Quantum Conventional Missile on it to see what would happen.  I think that wiped out one Datatech Isle.  Then I shelled a Datatech Spore Launcher with several warships, until it died.  Then a Gaian Sealurk appeared!  Bizarre!

Detailsninja engineering corpsninja engineering corps
I fight 2 more rounds of Gaian units.  Then my own Formers are finally revealed.  Maybe that's the end of it.  I saved the game.  I hope this long game doesn't go belly up and become unplayable.  If it does, apologies in advance.  At any rate, obviously I've won and it's only a matter of time.  I finish the year with 25k credits.

It's 5 PM.  I need to archive a large Yahoo! Group now.  I'm going to refrain from multitasking the game for the duration, in case the archiving tool / resource constraint is the source of the instability.

As of 11 PM I managed to grab the files and photos of the large Yahoo! Group, but I get errors when trying to get messages.  Oh well go figure.  It's not a list I own.  Worst case, I have my own personal emails I received from the group.  It's probably time to go up a GMail archiving learning curve as well.

DetailsPirates in my base!Pirates in my base!
MY 2360.  The bug has marched 1 square south, into my base!  I believe the mindworm pops are to blame somehow.  Now I've got Pirates showing up.  I believe the display of those units, is obscuring my own units, but that they're still there.  I'll work around this and try not to crash the game yet again.  Save attached again.

Detailsstack of 6 Formers up northstack of 6 Formers up north
The square north of my base had the bug last year.  It seems to contain a stack of Formers.  When I select 1 of those Formers, my view is moved to Gaian territory!  Are my units existing in 2 places at once?

Detailsstack of 6 Formers down southstack of 6 Formers down south
When I mouse over these 6 units, they have the same home bases as the units up north.  The last unit is from Gaia's Landing, so there's no way it could be up north.  I think the northern display is some kind of echo.  I will try moving the southern units, hoping the situation resolves.  Heh, maybe my Quantum units are quantum entangled!

Detailsocean gateocean gate
I'm definitely getting weird mirroring and teleportation effects.  When I moved a Former onto the previous turn's bugged square, I could swear it reappeared in my Gaian lands.  Now I notice Former mysteriously in the middle of the ocean, seemingly riding a Pirate Isle.  Whatever!  I will try not to move onto the bugged square anymore.

Detailsmy guys are going into the oceanmy guys are going into the ocean
Units that I put into my base, are getting dumped here!  This is not good.  The base that is giving me the buggy behavior, is home of the Manifold Harmonics.  I don't want to lose it.

Detailslesser targetlesser target
I send a Transport into the buggy city, hoping that will keep my units from drowning.  Looks like it worked, the units all loaded up.  But now I have to get them to safety, and I think nothing is guarding my buggy city!  Well, Pirates are "guarding" it.

Detailsfixing bugs with nukesfixing bugs with nukes
Well at least I'll have safe passage after this!

Detailsa doublea double
Detailscovering the escapecovering the escape
Detailsdelicious donut of deathdelicious donut of death
DetailsMidway IsleMidway Isle
I sure set off a lot of nukes this year!  I finish with 33k credits.

Detailsthey're crazy!they're crazy!
MY 2361.  I can't even veto them!  They're really determined.  I can't remember who proposed this either.

Detailsis it a wraparound limitis it a wraparound limit
Previously a bit under 4500 meters was the going rate.  I don't know if Planet can reach a maximum water height, or this has wrapped around with a bug, or the messages are just wrong, or what is going on.  It doesn't really matter, I'll just keep doing what I'm doing.  Minus the bugs.

Clicking on my bugged city froze the game.  I had to kill the process and load an autosave.

Detailsbig game hunterbig game hunter
Haven't done that in a long time!  I think I just took over a Locust and 32 Isles of the Deep.  Recently I figured out that my SAM R-Bolt ships can attack a Locust topped Isle stack directly, surely killing them all in 1 shot, at the cost of wounds.  My defensive needs haven't been very intense, so I'm putting my ships through a workout.

Oh no.  I foolishly accepted a prompt to move a unit in my bugged city.  The game froze again, forcing me to replay the turn.  I hadn't saved that glorious capture.  But!  As luck would have it, I reloaded the autosave and made the move against that very stack as my 1st move.  Got the capture again.  Go figure.  This time I saved it.  But will I be able to get through this turn?

Detailsmaybe wastefulmaybe wasteful
DetailsJesus ScoutJesus Scout
I Obliterate a base, and the offending Scout walks on water.  Maybe it's not a bug, but a Grace period.  I've seen mindworms carrying Isles do the same sort of thing at times, with the cargo hovering for the remainder of the turn after the Isle sank for some reason.

Detailsthe Gaian back 40the Gaian back 40
Detailsless land to shareless land to share
Detailscoastal liberationcoastal liberation
Detailsha ha hee hee ho hoha ha hee hee ho ho
Detailsdinosaur memorialdinosaur memorial
Detailsclean the waterclean the water
I make it to the end of my turn and finish the year with 43k.  I click on my buggy base to see what will happen.  It's now filled - seemingly! - with Former units and I'm able to allocate workers to squares.  I bet that's not the end of it though.

Detailsa fungus among usa fungus among us
MY 2362.  I started my game and between turns, it froze.  I figured I'd better look at my buggy city to see what might be causing it, even if that risked freezing the game.  OMG, there's a fungal tower growing in my city!  I don't even know how I'd get rid of that.  Is it the end of the line for my game?  Ok... I guess I could try to use the Scenario Editor to repair the damage, if I can't find any in-game way past this.  I've saved a game once again for this weird bug.

Detailsfungal tower eliminated with Scenario Editorfungal tower eliminated with Scenario Editor
After I ended my turn, the game immediately locked up again.  I saw no choice but to use the Scenario Editor.  I used the "Eliminate Units" function.  That seems to have eliminated the tower, and surprisingly, reveals a bunch of my own units inside the base.  I hope that stabilizes things.  I've saved a post-edited game in case I've succeeded.

Unfortunately it is not working.  I'll need to use the Scenario Editor to see if I can find any more anomalies.

I can't even load the edited save.  It freezes the game.  I'll have to go back to the "Fungal Tower bug" save.

I tried owning and then disbanding the Fungal Tower to get rid of it.  The game still freezes afterwards.  There could be more than 1 bug, so I'll need to stare at the map in the Scenario Editor more.

I haven't been able to find another anomaly.  I tried creating another fungal tower on top of the existing one, hoping that might somehow suppress or fix the bugs in the existing tower.  That caused the game to freeze immediately.

I tried taking ownership of the fungal tower and then playing on.  After my turn ended, the game locked up as usual.

I tried Activating the Scenario Editor, leaving it turned on, and making no other changes.  After my turn ended, the game locked up as usual.  I'm running out of things to try.

I tried lowering the base into the ocean, hoping to drown the Fungal Tower next year.  I saved that edit and was able to load it.  However once I ended my turn, same result, game freezes.

Detailsthe real 6 unitsthe real 6 units
Starting again, I get rid of the Fungal Tower using Eliminate Units.  Once I do that, 6 units are apparently displayed in my buggy city.  Clicking on any of them, recenters my view to 6 units inside a conquered Gaian city way down south.  I suppose the locations of these units are incorrectly linked or displayed somehow.  Perhaps if I relocate them, the problem will abate?

I create 2 Transports and move units out of 2 sea bases in Gaian territory.  Unfortunately my buggy city still displays the units even though I moved them out of base.  After ending my turn, the game still freezes.

Detailsmore ghost unitsmore ghost units
I go back to the original saved game with the bug.  I eliminate the Fungal Tower, then I eliminate the 6 ghost units in the city.  This causes 8 ghost Formers to become apparent.  The actual units exist on land to the west, and were used this turn to raise some terrain out of the water.  Eliminating the previous 6 ghost units, also caused the captured Gaian city of Virgin Soil to be completely empty.  I will continue to try to delete units to stabilize this.  However it's possible I might have to delete all my units, in this curious "ghost queue" faction, for this to stabilize.  If so, there won't be much reason to keep playing, as I do not really feel like doing the work of reconstructing my entire inventory of units.

Eliminating the 6 units doesn't cure it, indicating that I'll have to keep deleting.  I was able to load a save of that, and it worked briefly upon loading, but within 10 seconds of scrolling it locked up.  That's better than locking up when loaded, so maybe deletions do help.  It seems I'll have to hit some kind of "bottom" to free things up, if it's possible at all.

Detailsthis unit was Mining and can't be eliminatedthis unit was Mining and can't be eliminated
I Eliminate some more units, until I get to one I can't.  I haven't lost lots of units, although I wasn't paying good attention. 

It worked!  I am able to begin my next turn without lockup.  I'm attaching a save.  In the course of my turn I'll decide whether I feel it necessary to give myself units to replace what I lost.

Well, sorting that out took all morning.  It's now 1:30 PM.  I'm worn out from this.  This game will have to wait.  I almost regret being able to save this, as it's godawful tedious just dropping more QPBs slowly until victory finally comes.  If the game was hopelessly bugged, it would be a good excuse to quit!  But at least now I know how to get past this kind of bug if it ever happens again.

Know what?  I've had enough of this.  This morning's tedium, that was just ridiculous.  And I've dropped enough QPBs to make me sick.  It seriously gets old.  I have 2 AARs / DARs of "nuke porn" and enough is enough, I'm not doing it anymore.  I started this game more than 2 weeks ago, and lately it has become beyond dull.  So I quit.  Please just imagine more QPBs going off, as that's all there's left to say about the game.

Disappointed that only 1 person has had any comment on anything I've written.  That's not exactly encouragement to keep going, or to believe that there's an audience for the vast amount of work that a writeup like this takes.  Supply and demand, eh?  I definitely have other things I could be doing with Life.  Even if SMAC oriented, I'd sooner play and write up a new game with lessons learned, or try to tweak the AI's play yet again.

I'm at least pleased with how version 1.37 of my mod is holding up.  The tech progression is what I want it to be, I don't see any flaws in the long game.  I did notice that the Pirates obsess about producing Clean Transports.  I think they produced a couple hundred of those.  They did stop doing it eventually, and at least they weren't paying SUPPORT costs, but that's an awful lot of production that could have gone to something more useful.  I will try a game without the Clean Transport as a predefined unit and see how the Pirates do with that.  Maybe they'll build some other Clean unit instead.

Based on previous experience, I fully expected to die in this game.  But it turns out there's One True Enabling Technology: Air Superiority.  With that, you can knock out stacks of 32 Locusts, and probably sustain yourself in the face of any adversity.  Without it, you're dead.

So, any future game of this type, will be partially determined by when I acquire C5 Doctrine: Air Power.  I could make a bunch of chemical attacks before then, but once Planet goes into "stomp you" mode, I'd have to cease and desist until I've got that tech.

I'm not clear on whether Planet hates Obliterations.  That would be a good thing to test in the early game.  Can I get away with more of those than chemical attacks?  If so, then going after weakly defended bases with conventional units would be a good strategy.

I'm also made to realize that the number of "eco-friendly" facilities built isn't going to matter.  Nor probably the ultimate mineral output of my factories, at least once I've got the forces to defend myself.  Can't pull the Lion's tail until I'm ready, but I was too timid in this game about it.  The consequence is in the endgame, I was waiting a long time for a sufficient number of QPBs to be produced, when I probably didn't need to.

I had no idea how to use all the money I got, and I probably still don't.  I probably shouldn't be afraid of using it to make more technological progress, such as spending on research facilities.  For a long time I was more worried about having sufficient forces to withstand mindworms, but I actually passed that threshold without much problem.  Taking over bases with money still seems obnoxiously expensive though.  The inefficiency of my money, bugs me about this game.  It's one of the big itches that makes me want to start over.

Flooding is a bear.  Producing Super Formers won't solve it either.  I can use them to reconnect rail networks and make Scouts available to kill mindworms, but for propping up receding shores, they basically don't work.  At least, they can't maintain a static boundary that preserves ocean shelf terrain improvements.  They'd have to exceed those limits, because the floods are going to beat back the shores so quickly.  It seriously gets old trying to maintain shores every year, only to find that they're about to sink again.

Tectonic Missiles didn't seem so useful in the face of the flooding, because the land that is raised, has to be terraformed all anew to be worth anything.  Ocean improvements are preferable as once built, they don't go away.  However, ocean shelf does sink to ocean and then deep ocean, preventing terrain improvements until it is raised.  It is important to get ocean shelf developed quickly, or else build a large fleet of sea formers to raise what couldn't be gotten to.

The Pirates have the ability to terraform ocean and deep ocean squares, once they learn Advanced Ecological Engineering.  However I've never seen the AI do it.  I just checked a Pirate game to be sure they really have the ability, and they do.  A human player could take full advantage of that.


[0] Message Index

[*] Previous page

Go to full version