Alpha Centauri 2

Community => Chiron News Network => Topic started by: Yitzi on February 20, 2017, 02:00:24 PM

Title: Yitzi's Unofficial SMAX patch 3.5d
Post by: Yitzi on February 20, 2017, 02:00:24 PM
Yitzi's Unofficial SMAX patch 3.5d

http://alphacentauri2.info/index.php?action=downloads;sa=view;down=352 (http://alphacentauri2.info/index.php?action=downloads;sa=view;down=352)

This update fixes a bug with the effects of inefficiency on energy production at 100% energy.
It requires all files (other than terranx.exe) from version 3.5.
Title: Re: Yitzi's Unofficial SMAX patch 3.5d
Post by: Miranori on April 11, 2017, 04:10:28 PM
Hi,
I have problem with starting SMAX 3.5d (I am also tested 3.5c without success).
Win 10 , clean instalation AC from GOG.

After run I see "bad technology" see picture in attachment and then i see windows error message "terranx stop running".

Thanks for help.


ALPHA CENTAURI.INI
[Alpha Centauri]
ForceOldVoxelAlgorithm=1
DisableOpeningMovie=1
DirectDraw=0
ds3d=0
eax=0
FastUnitAnim=0
SmoothUnitAnim=0
MainFontSize=16
InterludeFontSize=16

[PREFERENCES]
ForceOldVoxelAlgorithm=1
DisableOpeningMovie=1
DirectDraw=0
ds3d=0
eax=0
FastUnitAnim=0
SmoothUnitAnim=0
MainFontSize=16
InterludeFontSize=16

Title: Re: Yitzi's Unofficial SMAX patch 3.5d
Post by: Buster's Uncle on April 11, 2017, 05:13:51 PM
That looks like you're not using the alphax.txt from v.3.5...
Title: Re: Yitzi's Unofficial SMAX patch 3.5d
Post by: Miranori on April 11, 2017, 05:39:03 PM
Ok, and where I could download it?

(I am only download terranx.exe 3.5d and replace original one....)
Title: Re: Yitzi's Unofficial SMAX patch 3.5d
Post by: Buster's Uncle on April 11, 2017, 05:49:36 PM
I think it's in the .zip at this link: http://alphacentauri2.info/index.php?action=downloads;sa=view;down=346 (http://alphacentauri2.info/index.php?action=downloads;sa=view;down=346)
Title: Re: Yitzi's Unofficial SMAX patch 3.5d
Post by: Miranori on April 11, 2017, 08:11:12 PM
Thank, now it run.
Title: Re: Yitzi's Unofficial SMAX patch 3.5d
Post by: SMACfirst on May 07, 2017, 03:29:56 PM
Hello

I always loved to play SMACX on my old computer. Since I have a new one (same OS: Win7 64bit) the game did not start anymore an I could not play. Fortunately I found Yitzi´s  patch 3.5d and now it works again!!

THANK YOU FOR THIS PATCH!!!!!!!!!!!!!!!!!!

Still, I have two things disturbing me:
1.: all the secret-project-videos dont run. If I get the project done, there´s only the notification window, no video. Also the "interludes" are completely lacking. and yes: I have the required checkbox checked in the Audio/Video preferences.
Has this something to do with this patch? has anyone else got this problem too? is there an easy solution for this?

2.: for the Map-Graphics there are new choices now, for elevation, faction, rockyness,.. but they don´t seem to work: if I try them there´s just an absolutly senseless color-salad that has nothing to do with the chosen theme and it stays always the same, does not change whatever I choose, so I can only use the standard (which is OK). What could be the reason for this? has anyone else got this "problem" too?

The "problems" aren´t too bad of course, because I´m so happy with the patch giving me SMACX back!

Thanks in advance to everyone helping me with this!
Title: Re: Yitzi's Unofficial SMAX patch 3.5d
Post by: RetroGamer85 on August 09, 2018, 06:46:28 PM
Hello,
Can somebody please help me? Here is my story and current problem -
Alpha Centauri is my favourit game of all time. I still have my original disk of the Windows 98 game.
I played it on my Windows 98 computer for years, until recently when after 20 years that computer finally stopped working. I have spent literally thousands of hours playing Alpha Centuari.
However i never got to experience the Alien Crossfire update. It wasn't released in my region, we didnh't have the internet and my finance's have always been limited.


Ok, so i bought a new desktop computer. Windows 10, Dell optiplex 780. And i now have amazon account. So, i wanted to experience the Alien Crossfire expansion pack for my favourite game, i've been waiting 20 years to play this expansion pack!

So i go looking to buy it - and it's nowhere to be found. Eventually i find a "Complete" version of Alpha Centauri featuring the Alien Crossfire expansion pack for sale on Amazon, i buy it and it finally arrives today.

Now, when installed Alpha Centauri using my Windows 98 copy onto my new Windows 10 pc - it worked.
However, the only available copy of Alien Crossfire i could buy was the Windows Vista version.
I installed it and it won't work. It won't play. The autoplay opens, and it comes to the screen about choosing Classic or Alien Crossfire.
I select Alien Crossfire, the programme never starts, just goes to my desktop.

I run it in compatibility mode... still nothing. I troubleshoot, read all the forum questions i can, try everything... nothing works, it won't initialise.

I am absolutely gutted. I've been waiting to play this expansion pack for 20 years. I don't have a lot of money and never have. So i am still playing the old games that I did when i was a kid.

I am kind of computer savvy, to a degree, but when it comes to talking about patches and updates and .ini files and directx drivers and graphics cards - i'm out of my element. I would need clear and precise instructions and or links to the specific files and exact instructions on what to do.


I figure this is a shot in the dark, a help cry into the void of endless space. The Windows 10 computer i bought probably isn't top quality, but it's all i could afford. I had my last pc since 1998, never had any mods done to it or had internet for it. So i just wanna be able to play Alien Crossfire on my new computer and it won't work for me.


I have a copy of disks of Alpha Centauri (Windows 98), Alpha Centauri (Vista), Alien Crossfire (Vista). And my computer i a desktop with Windows 10. I've spent the last 3 or 4 hours looking through forums, trying to download patches and updates and trying to figure this out but i just can't get anything to work.


Please, any help would be incredibly appreciated.

Thank you.
Title: Re: Yitzi's Unofficial SMAX patch 3.5d
Post by: RetroGamer85 on August 09, 2018, 10:59:00 PM
Ok so I've made some progress but still have problems.
I installed itzi's 3.5d patch. I then used the alphax text file and alphacentauriini file from - http://alphacentauri2.info/index.php?action=downloads;sa=view;down=346 (http://alphacentauri2.info/index.php?action=downloads;sa=view;down=346)

Now the game starts when I run the terranx file as an admin in compatibility mode.
However - the video files don't work now, they are extremely laggy.
And after about 50 turns the game just crashes and I am back on my desktop home screen.
Any further help or advice is very much appreciated!!
Title: Re: Yitzi's Unofficial SMAX patch 3.5d
Post by: Vidsek on August 12, 2018, 12:59:47 PM
   I doubt I can/could be much help getting your Vista copies of SMACX to work, but there is another source of the game that might give you a copy that will work on your new rig.
 GOG (Good Old Games) has a version that is already (pretty much) adjusted to run on Windows 10, and right here on the AC 2 site, we have instructions on how to install it and any necessary and/or wanted patches.
 Fortunately, GOG's price is pretty low, and they sometimes even have it on sale.
 This is the setup I and many of the other users of AC 2 have gone with, and most of us haven't had much trouble setting it up.  It works fine with Yitzi's, Kyrub's, and Scient's patches as well as the PRACX add-on/patch.
 Hopefully, you'll soon be back on Alpha Centauri cursing the native lifeforms again  :D
 If not...keep posting here, sooner or later one of us should be able to get you up and -wasting- gainfully employing your time in SMACX
Title: Re: Yitzi's Unofficial SMAX patch 3.5d
Post by: Vidsek on August 12, 2018, 01:22:50 PM
   This reply is to SMACfirst: the interlude and secret projects movies problem has been experienced by other folks.  There are threads somewhere in the forums addressing it and, at least for some folks, solving it. 
 The "food processor salad" graphics error you mention I have had as well.  My solution was to install Yitzi's latest patch without PRACX (and/or removing all the components of it), then installing the PRACX add-on/patch.  This made sure all the PRACX parts were the latest and compatible with each other.  After that, the map variations worked as intended and have been very useful.  Other folks have had the same problem, and again, there are threads somewhere in the forums detailing how they did or did not fix it.

  Hope this helps you find some solutions!
 
Title: Yitzi's Unofficial SMAX patch 3 5d
Post by: Kamdoni on August 07, 2019, 03:00:56 AM
It does SEEM like those crafting tables should perform some sort of function outside of what you can do on your own.  Otherwise, why keep them in game after beta and why add an additional one as if folks had been inconvenienced by not having one just there?

Are we missing something?  Has anyone checked lately?
Title: Re: Yitzi's Unofficial SMAX patch 3.5d
Post by: Buster's Uncle on August 07, 2019, 05:00:53 AM
-Can anyone tell me if Kamdoni is referencing something from games I'm not familiar with, or should I just quit waiting for the spam sig to be added and ban now?
Title: Re: Yitzi's Unofficial SMAX patch 3.5d
Post by: Vidsek on August 08, 2019, 04:47:50 AM
   Since there is no actual "crafting" in SMAC(X), it looks to me like a post for a different game/forum that accidently was posted here.  Unless Kamdoni gives us some more info, it's a mystery.
Title: Re: Yitzi's Unofficial SMAX patch 3.5d
Post by: frost on October 07, 2019, 08:38:03 AM
I play SMACX with Yitzi's patch (3.5d). Difficulty: Talent.

I can switch production of a facility to other facility (or a unit to other unit), but when I try to switch from facility to unit I can only add unit to queue.

Does anyone have the same problem?
Title: Re: Yitzi's Unofficial SMAX patch 3.5d
Post by: DrazharLn on October 11, 2019, 12:59:27 AM
That is odd and I don't have an answer for you.

But! I would love to know whether you did anything to get a nice font in SMAC in wine. I think I might have done it in the past by just providing my own arial.ttf, overriding the default one, but I don't remember. Maybe you did the same?
Title: Re: Yitzi's Unofficial SMAX patch 3.5d
Post by: frost on October 11, 2019, 02:56:33 AM
I found the problem.

I used PlayOnLinux to install and play SMACX with Yitzi's patch.

Then I tried to install and play SMACX with Yitzi's patch under VirtualBox (Ubuntu).
And the problem solved.